6

I followed every instruction I could here Org-mode 9: unable to eval code-blocks, and I am unable to get org-mode and org-babel to evaluate any code blocks in any language. I am dead in the water and I am throwing myself on the mercy of this community for help. I've spent the entire morning googling and reading and fenceposting and hacking with zero progress. All my org-mode files are dead!

Here is an MVE:

I stripped everything back to a fresh installation of spacemacs, and here is the version info evaluated in the *scratch* buffer:

(emacs-version)
"GNU Emacs 25.1.1 (x86_64-apple-darwin13.4.0, NS appkit-1265.21 Version 10.9.5 (Build 13F1911))
 of 2016-09-17"

(org-version)
"9.0.5"

0.200.9@25.1.1 (spacemacs)

and added

  (org-babel-do-load-languages
   'org-babel-load-languages
   '( (emacs-lisp  . t)
      ))

I also changed

'(safe-local-variable-values (quote ((org-confirm-babel-evaluate))))

into this

 '(safe-local-variable-values))

in an attempt to get anything at all to work. It doesn't matter what the value of that expression is, I get the same negative results, with no clues about what to do to fix it.

I have copied the whole .spacemacs here.

I tried to run the emacs-lisp code block that looks like this

#+BEGIN_SRC emacs-lisp :results output :exports both
    (princ (concat (format "Emacs version: %s\n" (emacs-version))
                   (format "org version: %s\n" (org-version))))

#+END_SRC

and made sure that the prevention codes are commented out

# By default I do not want that source code blocks are evaluated on export. Usually
# I want to evaluate them interactively and retain the original results.
# #+PROPERTY: header-args :eval never-export

* COMMENT babel settings
# Local variables:
# org-confirm-babel-evaluate: nil
# End:

I copied the entire org-mode file here.

No matter what I do, I get

Evaluation of this emacs-lisp code block is disabled.
11

Try doing the following:

cd .emacs.d/elpa/
# I suggest to run this without "delete" first.
find org* -name "*.elc" -delete

This will delete all compiled elisp files from org. The problem is likely to be caused by conflicts between Org Mode that ships with Emacs and Org 9.

Restart Emacs afterwards and everything should work fine.

  • I would have sworn I did this at least 20 times. This times it worked! – Reb.Cabin Apr 7 '17 at 15:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.