1

I am opening a Java source file which is part of a maven project. JDEE now runs maven once, which I can sort of understand. But whenever I move around in the file, it will trigger once more. Since it always splits my frame, and blocks Emacs, this is quite annoying.

Is there a how to or some rules on how to set up Emacs and JDEE for my Maven projects, so that this will not happen?

2
  • I agree! This is really annoying...
    – nephewtom
    Commented May 22, 2017 at 23:46
  • I did (jdee-maven-disabled-p t) to stop maven execution. Probably it is not my time for Java on Emacs... Who knows in the future...
    – nephewtom
    Commented May 23, 2017 at 2:33

1 Answer 1

0

The maven compile buffer only happens when you open the project the first time, try with mvn dependency:build-classpath -Dclassifier=sources to check is successful getting all the sources otherwise that will be the reason that why always run maven buffer on the startup

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.