0

I am following the directions laid out in this answer to edit my sshd_config file.

However when I try to save I get:

byte-code: Wrong type argument: listp, 126

Does anybody know why this would be and how I could fix it? (this prevents me from saving my file)

EDIT

Thanks to the comments I was able to narrow down the issue to the following lines in my init file:

(setq tramp-default-method "ssh")  
(setq tramp-auto-save-directory auto-save-location)  
(setq tramp-backup-directory-alist auto-save-location) 

Commenting them out fixed my issue

8
  • (1) Use toggle-debug-on-error to get a stack trace for the error. (2) Try editing and saving the file using a separate emacs -Q instance, which will indicate whether or not the problem was caused by your config.
    – phils
    Apr 13, 2017 at 1:28
  • Uh-oh. ``toggle-debug-on-error` does not print out anything different but trying (2) emacs -Q lets me save the file with no issues. I take it this means it is a problem with my config? Any ideas how to start debugging that?
    – Startec
    Apr 13, 2017 at 1:34
  • Yes. Recursively bisect your init file. Comment out 1/2 of it, then 3/4, 7/8, 15/16,... You can use command comment-region to comment out selected text. With plain C-u it uncomments. Sounds slow but is fast (binary search).
    – Drew
    Apr 13, 2017 at 2:11
  • After enabling debug-on-error, you tried to save the file again, yes? And it failed with the same error, but didn't produce a backtrace/debugger window?
    – phils
    Apr 13, 2017 at 2:30
  • Yes that is exactly what happened. In messages I see debug-on-error enabled globally but I don't get a stack Trace and the error is the same.
    – Startec
    Apr 13, 2017 at 2:32

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.