0

According to the documentation, the following setting enables subscript only in the form like ‘a_{b}’.

  (setq org-use-sub-superscripts nil)

However, in 'a_b', 'b' is still exported as subscript. How to export '_' as underscore?

1

According to the documentation in org-mode 8.2.10 the option that controls the export is org-export-with-sub-superscripts and not org-use-sub-superscript.

| improve this answer | |
1

The the curly bracket syntax has effect only on display. If you have complex sub/superscripts or have filenames with underscore (_), set org-use-sub-superscript to {}.

As pointed out in the other answer, the variable that affects export is org-export-with-sub-superscripts. Put this into your emacs config file and evaluate it for immediate effect:

(setq org-export-with-sub-superscripts nil)

or to set it only for the current buffer by adding the following line to the beginning of the file and activate it with C-c C-c.

#+OPTIONS: ^:nil
| improve this answer | |
  • If you want to disable it, you must set it to nil, not t. – NickD Apr 16 '17 at 11:36
  • That's right, I corrected the the option ^ to nil. – Heikki Apr 16 '17 at 13:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.