I have some issues when using the version control ( commands inside emacs (e.g.: vc-dir, commit, etc...). Here is an example of what is shown when I try to commit (C-x v v):

svn: E210002: Commit failed (details follow):
svn: E210002: Unable to connect to a repository at URL 'rep_dir'
svn: E210002: To better debug SSH connection problems, remove the -q option from 'ssh' in the [tunnels] section of your Subversion configuration file.
svn: E210002: Network connection closed unexpectedly

If I use the equivalent command in the terminal (such as svn commit -m "message") it works perfectly.

QUESTION: How can I debug what is going on in the version control commands inside emacs? Any debug buffer for the VC mode?


-----Details-------

My server recently changed its IP, but its hostname is still same (myserver.com). I suspect that in one of the files that emacs reads there is a cached mapping from hostname to IP. However, I don't know what the file is, and if this is actually the case.

I am using CentOS 7.

The protocol is svn+ssh.

Emacs version 24.3.1.

Please, let me know if you need any more detail.


--- Some stuff I tried ---

Here are some stuff that I tried.

In this page (https://www.gnu.org/software/emacs/manual/html_node/emacs/General-VC-Options.html#General-VC-Options) it says that setting the variable vc-command-messages to a non null value will enable the verbosity of the VC commands. However, I tried to set this variable but there is no match! M-x set-variable RET vc-command-messages [No match].

  • What about other commands that need to connect to the repository? Does C-x v l work or does it fail to connect to the repository as well? And what's "rep_dir"? Shouldn't that be the URL of the repository that it failed to connect to? – stevoooo Apr 21 '17 at 11:41
  • Does it help if you M-x load-library vc RET before trying to set vc-command-messages? – npostavs Apr 21 '17 at 12:20

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.