1

I want to use org-wikinodes (http://orgmode.org/worg/org-contrib/org-wikinodes.html)

Org wikinode is activated :

(setq org-modules (quote (org-wikinodes)))

I can follow wikinodes links with C-c C-o.

However, the wikinodes links are not clickable. In addition, when I open an org file, I have the following message :

"Failed to add wikinodes to ‘org-font-lock-extra-keywords’."

I saw in the org-list that this problem was resolved before (https://lists.gnu.org/archive/html/emacs-orgmode/2015-06/msg00738.html)

Emacs version:

GNU Emacs 25.2.1 (x86_64-apple-darwin15.6.0, Carbon Version 157 AppKit 1404.47) of 2017-02-15

Org mode version 9.0.5 (9.0.5-elpaplus @ /Users/sam/.emacs.d/elpa/org-plus-contrib-20170210/)

Does anybody have the same issue?

Best,

  • This issue is now resolved under Org-Mode 9.0.7 – sam Jun 9 '17 at 13:50
0

Find the line towards the end of org-wikinodes.el that reads:

(let ((m (member '(org-activate-plain-links (0 'org-link t))

and and change it to this:

(let ((m (member '(org-activate-plain-links (0 'org-link))

Then M-x byte-recompile-directory and path-to/org-plus-contrib/.

I honestly have no idea why this works... I just got lucky (perhaps someone else can chime in).

A couple of things to note about this:

If you ever update org-wikinodes.el your changes will be lost. Maybe there's a way to get this done in your init.el file instead?

I also notice that placing (setq org-return-follows-link t) in init.el has no effect links generated by org-wikinodes. No idea why...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.