0

so the problem I am having is that my spaceline plugin will have little squares of miss color until I do powerline-reset. (Just like the github issue.) Problem is that I am having to do this every time I start up emacs. Is there a way to make it so I don't have to do this every time I start up emacs?

Here is the issue on github: https://github.com/TheBB/spaceline/issues/11

(use-package spaceline
 :ensure t
 :init
 (progn
  (require 'spaceline-config)
  (setq powerline-default-separator 'wave)
  (setq spaceline-workspace-numbers-unicode t)
  (setq spaceline-separator-dir-left '(left . left))
  (setq spaceline-separator-dir-right '(right . right))
  (setq powerline-height 20)
  (setq spaceline-highlight-face-func 'spaceline-highlight-face-evil-state)
  (spaceline-toggle-major-mode-on)
  (spaceline-toggle-minor-modes-off)
  (spaceline-toggle-battery-on)
  (spaceline-toggle-hud-off)
  (spaceline-spacemacs-theme)))
| improve this question | | | | |
1

You should call (powerline-reset) as the last entry in your use-package config for spaceline. So it should look something like this:

(use-package spaceline
:ensure t
:init 
(progn 
  ;; size of modeline
  (setq powerline-height 18)
  (setq spaceline-highlight-face-func 'spaceline-highlight-face-evil-state)

  ;; slant (requires srbg support)
  (setq-default powerline-default-separator 'slant) 
  (setq spaceline-separator-dir-left '(right . right))
  (setq spaceline-separator-dir-right '(right . right))
 )
:config
(require 'spaceline-config)
(spaceline-toggle-buffer-size-off)
(spaceline-spacemacs-theme)
(setq spaceline-buffer-encoding-abbrev-p nil
      spaceline-window-numbers-unicode t
      spaceline-line-column-p nil
      spaceline-buffer-id-p nil
      spaceline-minor-modes-separator nil)
      (powerline-reset)
 )
| improve this answer | | | | |
  • This actually doesn't work. It is so weird. I don't get why I have to manually run this command :( I do appreciate your trying. – codingdraculasbrain Apr 23 '17 at 4:03
  • hmmm...have you tried separating things into init and config sections? I'm wondering if something is getting called that is interfering with (powerline-reset). – mclear Apr 23 '17 at 4:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.