1

I've configured the Java layer for my Spacemacs setup and am getting completion candidates using company-mode and the Eclim backend. However, everytime company-complete is triggered, I experience a short but noticable lag, which annoys me quite a bit.

Since I don't really need the autocompletion feature most of the time, I'd be glad if I can set up company mode in such a way that I have to trigger company-complete explicitly using a specific key binding (e.g. C-SPC, since that isn't really needed with evil-mode anyway).

I found no obvious candidate for this config option while browsing the company-* variables, and my Google fu hasn't turned up with any similar discussions so far. Just disabling company-mode using SPC : company-mode works, but triggering the completion using M-x company-complete during insert mode subsequently does nothing (except for printing a message that company was disabled). Same goes for toggling auto completion using SPC t a.

  • Does company-idle-delay look relevant? – Dmitry Apr 30 '17 at 19:48
  • Yes, setting company-idle-delay to nil seems to do the job. Do you want to post that as an answer so I can accept it? – mfrischknecht May 2 '17 at 5:10
1

You need to set company-idle-delay to nil.

Quoting its docstring:

The value of nil means no idle completion.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.