1

I am opening emacs in --no-window-system mode and I switched xterm-mouse-mode on. Mouse clicks within a buffer work. However, I want the menu at the top of the window to open when I click on it.

I.e., when I click on File, I want the dropdown menu to show up the list with the options to open a file or to save the current buffer and so on.

What happens actually instead is that on the right half of the shell window a new buffer opens, showing a message like the one visible here: like the one visible here.

How can I get the menu bar at the top of emacs to work as I expect it? I want the ordinary behaviour from all other "normal" GUI editors, which do not operate on the command line. Thanks in advance!

2

I want the ordinary behaviour from all other "normal" GUI editors

But you're not running it as a GUI editor, you're running in a terminal.

When menu-bar-mode is enabled (as it is for you), you can type <f10> to open the menus, and then navigate with the keyboard.

Or you can use the menus regardless by typing M-`

You may be able to get some mouse interaction by enabling xterm-mouse-mode in Emacs, but that won't necessarily do what you want for the menus. (In my case clicking on the menu names triggers the M-` behaviour for that menu.)

  • So there is no way to use the top menu completely by the mouse? – Gerhard Hagerer May 1 '17 at 7:17
  • I don't know. The fact that xterm-mouse-mode exists and is able to detect clicks on the specific menu toolbar items, combined with the fact that the menu UI opened by <f10> is otherwise what you're after, does make me think that it may be possible to combine those two things to get the result you're looking for. I haven't looked into that myself, though. – phils May 1 '17 at 9:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.