0

I have a large text file that's over 8 MB. I can't really open it in desktop Emacs since it takes at least 30 seconds just to open the file via find-file, and it takes like 10 seconds for the screen to refresh appropriately when scrolling just one line or so. I tried setting the mode to fundamental, copying the whole text from the large file I mentioned that's opened in Sublime Text 2, and pasting to the emacs' buffer, and the text didn't show in 30 seconds so I killed the whole process. In Sublime Text 2, on the other hand, it just took 2 seconds to paste the whole text to another text file.

This doesn't happen in the terminal version of Emacs. Nor in other similar text editors like Atom or Sublime Text 2.

My Emacs: 24.5 (9.0) for OS X desktop.

  • As you're using OSX, which seems to be notorious for causing people to inadvertently run Emacs 22 from the command line, can you please start emacs in the terminal and then check M-x emacs-version – phils May 6 '17 at 13:16
  • @phils, so does this happen only in my environment? It says 24.5.1. I thought this was a common issue because I saw questions on how to make emacs handle large files faster and the typical answers are open such files in fundamental mode and disable linum mode. – stacko May 6 '17 at 14:48
  • 1
    Try it with no init file (emacs -Q). Same issue or not? – Dan May 6 '17 at 15:07
  • This isn't normal - I regularly work with a text file ~3MB with short delays (1-2 seconds lag every 10-20 min). Nothing like what you describe. The problem could be on the Emacs side, or an interaction between the Emacs GUI and your operating system. If the problem goes away when you load emacs with the emacs -Q option, then it's something you can fix by working through your init file. If the problem persists, it's something at the OS level that may be trickier to sort out. – Tyler May 6 '17 at 16:25
  • See @Dan's comment. That's the first thing to check, to see if something in your init file is the culprit. If not, provide a minimal, step-by-step recipe to repro the problem, starting with emacs -Q. – Drew May 6 '17 at 16:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.