I can not insert any image to an .org file and export it to .pdf or .html file under MacOs X.

On the other hand, Ubuntu does successfully generates the image. In fact, it also shows the image inside org file. In both Os, I enabled inline-images but MacOs X does not do anything.

Did anyone encounter with the same issue and resolve it ?

  • Are you using the same version of Emacs/Org on both machines? Have you double-checked that the image path is correct on the OSX machine, and that the image file is present and readable?
    – phils
    May 7 '17 at 16:10
  • I can not check the org version on the ubuntu machine right now, but with high probability on MacOs X machine has the latest version of both emacs(25.2.1) and org-mode(9.0.6) because I installed them 2 days ago. The path is correct. One other thing I noticed that is I can open the image, which is .jpg file by the way, with Safari and Preview but not with Chrome. May 7 '17 at 17:02
  • Try a different image. Perhaps the data is corrupted.
    – phils
    May 7 '17 at 22:09
  • I tried with different images. By the way, all org-modes that I have are above 9.0 . May 8 '17 at 8:03
  • So none of the jpeg images open in Emacs or Chrome? If so, I'd guess there's an issue with a jpeg image library on your system (with Safari etc presumably using a different library).
    – phils
    May 8 '17 at 8:20

After many hours, finally solved the problem - it is mechanical though. Here are the steps :

  1. Be aware that you installed imagemagick from your favorite package installer - homebrew, macports or other.
  2. convert your image to jpeg by using "convert" command. Not by changing the .jpeg in information window (cmd + i).

Finally I can insert images! But still I need to convert each image manually.

The conversion idea comes from this link [https://tex.stackexchange.com/questions/166319/including-a-jpg-image-source-code-compilation-in-pdflatex-doesnt-create-pdf] (from tex.stackexchange.com)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.