3

I'm using Emacs 25.1, and I use it primarily for LaTeX with AucTeX. Some time ago in the directories of my .tex files, there started to appear a folder named "auto" with .el files in it. The .el files look like this:

(TeX-add-style-hook
 "nameoffile"
 (lambda ()
   (TeX-add-to-alist 'LaTeX-provided-class-options
                     '(("article" "11pt")))
   (TeX-run-style-hooks
    "latex2e"
    "article"
    "art11"
    "amsmath"
    "amssymb")
   (TeX-add-symbols
    "R"
    "Z")
 :latex)

EDIT: So I found out that this is probably triggered by enabling parse on save. Is there a way to stop automatically generating these files?

4

You can disable parsing when you save your file with this line in your init file:

(setq TeX-auto-save nil)

Now you can trigger parsing with C-c C-n manually. When you do this, AUCTeX will still save a docname.el in a subdirectory auto. If you dislike this, you can set the variable TeX-auto-private to a directory of your choice. AUCTeX will then save all parsing information in that directory. The drawback is that you get confusing completion if you have different files in different directories with the same file name.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.