1

I recently upgraded my Emacs to 25.2.1 via dnf package manager (Fedora 25) and the edition of remote files via tramp and ssh is failing on Solaris 10 hosts (The same kind of editing is working on a Linux). Before the upgrade, I had no problem with Solaris.

I have got some details by increasing tramp-verbose to 4:

13:52:52.259282 tramp-barf-unless-okay (1) # File error: ‘tramp-histfile-override’ uses invalid file ‘~/.tramp_history’

tramp-histfile-override seems to be a new thing introduced with Emacs 25.2.

By trial and error, I have found that the following make it work:

(setq tramp-histfile-override ".tramp_history")

Simply replacing ~ by $HOME do not work neither. So it seems to miss some variable expansion.

  • May I consider that it is a bug? If so, I did not report problems to the EMacs devs for a very long time, can you tell how to do nowadays?

  • If it is not a bug, would it be possible to keep the default value ~/.tramp_history for some hosts while using another value for Solaris hosts?

EDIT: It took time to get a log of failure because the remote editing unexpectedly became functionnal as before. Today after a system reboot, it is failing again. (WTF?!)

I had suspected the mail indicator ("you have [new] mail") at login to brake the prompt detection, but it seems not to be the guilty.

I have put the log in a pastebin as it is too big for the question edit box.

2

First of all, it would be helpful to see Tramp traces with tramp-verbose set to 6.

I don't know whether this is a bug, or something related to Solaris 10 and the shell you are using there. For this I would need to see the more verbose traces.

A good setting for tramp-histfile-overrideis "/dev/null", provided you don't use a buggy bash on the remote side.

Changing this variable to different values for different hosts will be possible with Emacs 26. We are introducing connection-local variables there, which provide exactly this feature.

  • I worked again for a number of days, then broke again today after a reboot. I have updated my question with the debug log. – Seki Jun 2 '17 at 10:05
  • According to the traces, it is still the same HISTFILE=~/.tramp_history setting. Didn't you change tramp-histfile-override. – Michael Albinus Jun 4 '17 at 11:25
  • I did emptied the the tramp-histfile-override to test but not in a permanent way, and Emacs has been restarted many times so it retrieved its normal value with tramp still functional. Weird problem. Hopefully, remote editing on Solaris will become useless as the hosts are being migrated to Linux. – Seki Jun 5 '17 at 18:12
0

I experience this same issue intermittently some machines and have used Michael Albinus' recomendation successfully.

A good setting for tramp-histfile-override is "/dev/null", provided you don't use a buggy bash on the remote side.

Below is a quick fix if you don't want to permanently update your emacs configuration:

M-: (setq tramp-histfile-override "/dev/null")

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.