1

The purpose of this question is primarily to serve my curiosity, but it can maybe save some time for others who may press C-M-s (isearch-forward-regexp) just like they would press C-s (isearch-forward), but who would see nothing happening.

In fact, when I press C-M-s just like I would for any other keystroke, nothing happens, and I lately figured out I had to hold it pressed for about half a second for it to work.

This is also the case if I want to get the description of C-M-s using C-h k.

What is the reason for that? Is it related to my configuration?

  • To test whether it is related to your configuration, try starting emacs as emacs -Q under both terminal and graphical environments. I guess the keys could conceivably be intercepted by the terminal emulator or window manager. – Basil May 29 '17 at 11:05
  • @Basil Did you mean "emacs -q" ? – Giuseppe May 29 '17 at 11:46
  • No, but you can try that too; -Q implies -q in addition to disabling other custom initialisation code that may be installed on your system. See here for more information. – Basil May 29 '17 at 11:58
  • After trying starting Emacs that way (both with and without GUI), the result is the same. Only with the -Q option the GUI window is minimized when I press C-M-s. – Giuseppe May 29 '17 at 12:20
2

This was apparently due to Ubuntu (with Unity): C-M-s was in my case a default key-binding for minimizing windows.

Hence a conflict, I guess. Redefining it to something else solved the problem.

0

C-h f isearch-forward-regexp, then you will find:

C-M-s (translated from C-M-S-s) runs the command

C-M-S-s works(GNU Emacs 25.1.1) for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.