1

How can I make org-babel only export results, not code? The only way I've found to suppress code from appearing in the output is to comment out all the code blocks manually. I tried adding :exports results but it still includes the code.

I'm using Emacs 25.2 with org-mode 9.0.6.

  • You mean that :exports results has no effects? #+BEGIN_SRC python :exports results works fine for me and the export only includes results and no code. Can you show us your src block? – dangom May 31 '17 at 20:52
  • Good point. I used R in my source blocks. But, I was worried that I was misunderstanding what :exports results was trying to do. – wdkrnls May 31 '17 at 20:53
  • Have a look at the org docs about exporting. They explain all options and what they do. – dangom May 31 '17 at 20:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.