-1

All of sudden, XEmacs 21.4.22 starts asking whether it should chmod a+x $f everytime I try to save a buffer that is in Shell-script mode.

  • Switching it to fundamental-mode stops that behaviour.
  • enabling shell-script-mode again doesn't make the question asked again
  • I spot 'AScmd' mentioned on the buffer flags area.

As far as I know, "AScmd" stands for "After Save command". I guess I accidentally enabled it.

My questions:

[x] what is triggering that question ? -- likely an After Save command

  • what enabled that ?
  • how can I get rid of it ?
  • Provide a recipe to reproduce the problem, starting from Emacs with no init file. (In GNU Emacs that would be emacs -Q. – Drew May 31 '17 at 16:25
  • Looking at xemacs.org/Documentation/21.5/html/xemacs_6.html, XEmacs doesn't support -Q, but -q --no-site-file should be equivalent. – npostavs May 31 '17 at 17:29
  • 1
    You can hit C-h m to see which mode AScmd indicates. If that does not answer the question, you can toggle debug on quit, then reproduce the prompt and hit C-g while in the prompt. It will give a backtrace that you can inspect, to see where the question came from. – YoungFrog Jun 1 '17 at 9:03
  • @YoungFrog: interesting, but unfortunately I don't see AScmd mentioned anywhere here. – PypeBros Jun 2 '17 at 7:31
  • @Drew, the problem doesn't appear when I just call xemacs --no-site-file <filename> and then enable font-lock-mode. But it doesn't occur either with my initialization code with just setting font-lock-mode. – PypeBros Jun 2 '17 at 7:32
1

Do the following:

  • M-: (setq debug-on-quit t) RET
  • reproduce the problem
  • when asked whether to perform the chmod, hit C-g
  • hopefully this will give you a backtrace showing which code is doing that. If you don't know what to do with that backtrace, you can post it here.
  • upgrade: XEmacs-21.4.22 was released in Jan 2009, you deserve better
| improve this answer | |
  • That's interesting, but unfortunately, didn't helped at investigating the problem while it was there. The problem hasn't re-appeared since then. – PypeBros Aug 23 '17 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.