1

I tried to install pdf-tools under emacs 24 and Ubunt 16.04, like I did it several times succesfully.

But now I get the error messages:

Symbol's function definition is void: pdf-tools-install

PDFs are still opened with the docview mode.

When I use M-x pdf-tools-install after Downloading from Melpa I get the message "Sever build succesfully".

Any ideas what's gone wrong?

  • Set debug-on-error to t. Post the backtrace. Some code you are invoking tries to invoke function pdf-tools-install, but the code that defines that function has not been loaded. – Drew May 31 '17 at 16:22
  • 2
    That function should be autoloaded by package-initialize. – politza Jun 1 '17 at 0:30
  • 1
    My guess is that you are trying to run that code before packages are initialized. Try adding (package-initialize) near the beginning of your init file, and definitely before trying to invoke pdf-tools-install – YoungFrog Jun 1 '17 at 9:07
1

(package-initialize) was missed in my init.el.

Thanks to all for your help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.