5

The following is my failed attempt at installing org-drill on Spacemacs.

I tried following instructions on https://bitbucket.org/eeeickythump/org-drill But there is no "org-modules" in my .spacemacs file. And there is no .emacs file on my Spacemacs install.

So I added "org-plus-contrib" to .spacemacs file as described in org-drill doesn't load with spacemacs configuration

I added "org-drill" to .spacemacs file, dotspacemacs-configuration-layers.

When I run dotspacemacs/sync-configuration-layers and reload the config file with SPC f e R I get the following message:

FAIL: org-drill

What is the proper way to install org-drill on .spacemacs?

Update

Thanks to Nick I successfully installed org-drill on my Spacemacs. org-mode was already installed. The org-drill install went something like this:

Press C-h v
Describe variable: org-modules
Press RET.
In help buffer, move point to "customize" link and RET.
Scroll down and check "External packages:"
Package: drill
Click "State" button and "Save for Future Sessions"
Run dotspacemacs/sync-configuration-layers SPC f e R
Done.
Check box "drill" is now in list, check it.
Scroll up and click "Apply and Save" button.
Run dotspacemacs/sync-configuration-layers SPC f e R

enter image description here

  • I'm wondering if when you entered in customize your action took some effect. Check if your custom-set-variables has some reference to org-modules variable. – Alexandro de Oliveira Jun 3 '17 at 4:51
  • <kbd>C-h v</kbd> Describe variable: custom-set-variables<br> No variables are listed. – wolfv Jun 3 '17 at 5:08
  • No, I mean, your custom-set-variables session at the end of your .spacemacs config file – Alexandro de Oliveira Jun 3 '17 at 5:10
  • For your knowledge, when you ask for customize a variable the config file is edited automatically which the choices you asked. In this case, if you customize the org-modules variable one entry in the section custom-set-variables is automatically created. So, if your variable is not defined anymore I guess some modification to this section of your config file could be changed. – Alexandro de Oliveira Jun 3 '17 at 5:16
  • My .spacemacs file does not have "org-modules". The end of my .spacemacs file is appended to the question. – wolfv Jun 3 '17 at 6:05
6

In fact your org-modules variable is not set in your .spacemacs file.

In order to see or change this variable you need to call:

C-h v , type org-modules and then press RET.

In the help menu that pops up you can see its value and also to customize it using the proper UI as explained in the Emacs manual Easy Customize, but if you are confortable with manually editing your config file the procedure is very simple and described below:

First take note of the original value of the org-modules variable.

Now insert the whole variable in the custom-set-variables section that is the end of your .spacemacs file, adding org-drill at the end, like this:

(custom-set-variables
 '(org-modules
   (quote
    (org-bbd org-bibtex ... org-drill)))
...
)
  • 1
    Thanks Alexandro. I appended a "Update 1" to the question. – wolfv Jun 3 '17 at 4:46
0

In fact you can set the variable org-modules in your Emacs init file. Below is my settings:

enter image description here

You can see the org-drill module listed in this variable. Also do not forget to add (require 'org-drill) in your init file. You can include whatever you want here to make it loaded in Emacs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.