0

My user-config looks following:

(defun dotspacemacs/user-config ()
  (setq-default dotspacemacs-configuration-layers
   '((erc :variables
      erc-server-list
      '(("chat.freenode.net"
         :port "6697"
         :ssl t
         :nick "siulkilulki")))))
)

According to point 3.4 in http://spacemacs.org/layers/+chat/erc/README.html it should set default servers, but when I press <leader>aiD I get you must define erc-server-list. What did I do wrong?

0

It seems like dotspacemacs-configuration-layers should be set up in defun dotspacemacs/layers (). Moving code there solves problem.

0

It looks like when ERC starts it doesn't actually use the default servers unless you tell it to. Having two possibilities for default servers seems odd.

M-m a-i-D (it has to be a capitalized D) starts the default servers for me. Anything else starts on freenode.net with port 6667

For reference in my dotspacemacs-configuration-layers I have the following format for my default server:

   dotspacemacs-configuration-layers
   '((erc :variables
          erc-server-list
          '(("irc.example.com"
               :port "6770"
               :ssl t
               :nick "nick"
               :password "password"))
          ))

UPDATE: What I ended up doing was making my own key setting to join the IRC server I wanted (C-c i):

  (global-set-key "\C-ci" (lambda () (interactive)
            (erc-tls :server "irc.example.com"
         :port "6779"
         :nick "my_username"
         :password "my_password")))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.