12

Moving around point (using the cursor keys) in Xah’s unicode.txt in fundamental-mode is noticeably slower than in an ordinary text file. Are the many non-ASCII characters the issue? Anything else?

About: GNU Emacs 25.2.1 (x86_64-w64-mingw32) of 2017-04-24 started with option -Q

3
  • I can see all characters and I do not have slow downs, neither in text-mode nor fundamental-mode. I'm using 24.5 GTK with Linux. How are you moving point, by keyboard input?
    – jue
    Commented Jun 13, 2017 at 12:50
  • 3
    github.com/purcell/emacs.d/issues/273 see if this is relevant.
    – wvxvw
    Commented Jun 13, 2017 at 12:57
  • I see no problem on OSX either using Emacs 25.2.1.
    – lawlist
    Commented Jun 13, 2017 at 16:09

1 Answer 1

17

Reading the GitHub discussion thread linked in @wvxvw’s comment, I discovered the variable inhibit-compacting-font-caches. Setting it to non-nil solves the issue:

(setq inhibit-compacting-font-caches t)

Now navigating point is fast. According to the variable’s documentation, inhibiting compacting font caches comes at the expense of more memory usage, which is fine for me.

See also bug 27350 filed by @Drew.

5
  • You can accept your own answer (or any other answer, if you want to wait for others).
    – Drew
    Commented Jun 13, 2017 at 14:24
  • 1
    I just filed an enhancement request (bug #27350) to make the variable customizable.
    – Drew
    Commented Jun 13, 2017 at 14:35
  • 1
    I also filed bug #30539, which is similar - involves slowness due to the same variable.
    – Drew
    Commented Feb 23, 2018 at 2:48
  • Thanks that really works for me too. Commented Oct 29, 2018 at 18:33
  • Still works for Emacs 26 Win 64
    – Carsten H
    Commented Nov 4, 2019 at 9:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.