My computer crashed whilst using emacs to ssh open a file. This was not related to emacs but an overheating problem. Since then emacs hangs every time I try and open a remote file using ssh

I press ctrl-X ctrl-f

then type :


But the colon never appears and emacs hangs.

I have tried copying in the path I want to open and it still hangs.

I have tried using emacs in the terminal with the -nw option it still hangs.

I can still open normal files.

I am using ubuntu 16.04

I am an emacs beginner so please bear that in mind in your answers.

  • 1
    maybe tramp chocked on his history file? Try to delete .emacs.d/tramp
    – jue
    Jun 16 '17 at 7:10
  • Thanks for the suggestion but that did not work.
    – user27815
    Jun 16 '17 at 9:01
  • maybe it is not tramp but ido try to delete (or better just rename) .emacs.d/ido.last. You could also try to run emacs -Q and then try to ssh, it works little different because ido is not activated.
    – jue
    Jun 16 '17 at 9:22
  • Thanks I did not have an ido.last file but I saw some session files and I removed them and that worked. Thanks for pointing me to the folder.
    – user27815
    Jun 16 '17 at 9:39
  • 1
    Can you do M-x toggle-debug-on-quit and then when Emacs hangs, hit C-g and see if you get a *Backtrace* buffer?
    – npostavs
    Jun 18 '17 at 23:09

One time I removed the session files from .emacs.d and that worked.

But I have another instance of this problem and there are no .session files to delete so the problem is still there now.

  • 2
    Could you please name the files? The next user maybe will be glad about the names.
    – jue
    Jun 16 '17 at 9:48
  • 1
    The files began session.
    – user27815
    Jun 16 '17 at 9:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.