1

I'm fill my org-mode file with Cyrillic tasks names, and when i try generate TaskJuggler export file i'm got error:

org-taskjuggler-compile: TaskJuggler failed with errors: Error: UTF-8 encoding 
error in line 11:   task __________ "<?><?><?><?><?><?><?><?><?><?><?><?><?><?><?><?><?><?><?><?> <?><?><?><?><?><?><?>
<?> <?><?><?><?><?><?><?><?><?><?><?><?><?><?><?><?>" {

Not sure so its related with TaskJuggler but i'f found this line in source code on github.

And second, from command line exported file *.tjp to html report going fine. Maybe i must something configure in the SpaceEmacs?

1

Setting language environment variables in Emacs helped in my case:

(setenv "LC_ALL" "en_US.UTF-8")
(setenv "LANG" "en_US.UTF-8")
(setenv "LANGUAGE" "en_US.UTF-8")
(setenv "LC_COLLATE" "en_US.UTF-8")
(setenv "LC_CTYPE" "en_US.UTF-8")
(setenv "LC_MESSAGES" "en_US.UTF-8")
(setenv "LC_MONETARY" "en_US.UTF-8")
(setenv "LC_NUMERIC" "en_US.UTF-8")
(setenv "LC_TIME" "en_US.UTF-8")

Check what locale settings you use in shell environment by running locale and set your emacs variables accordingly.

3
  • You might like to describe your case (in as much detail as possible).
    – Stefan
    May 28 '18 at 0:15
  • Yes, it's work!
    – Bimawa
    May 28 '18 at 10:04
  • @Stefan I use spacemacs and just added this code in (defun dotspacemacs/user-config () function in .spacemacs dot file.
    – Bimawa
    May 28 '18 at 10:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.