I am using tabbar and some settings for smooth scrolling which seem to conflict with each other in a weird way. Here is a minimal init.el file:

(setq mouse-wheel-scroll-amount '(1 ((shift) . 10) ((control) . 30)))
(require 'tabbar)
(tabbar-mode t)
(setq mouse-wheel-progressive-speed nil) 

With these settings, if I now try to scroll a moderate length (600 long lines) tex file in the AucTeX mode, it jumps back, i.e. if I scroll, say, up, and look at the percentage bar, it goes 70,69,68,67, and then jumps back to 70,69,68,67,... If I move the point somewhere else and start scrolling again then it scrolls ok for a while but then again starts cycling around. Disabling tabbar mode makes the issue disappear. Is there maybe a setting that could prevent tabbar from affecting this scrolling behavior in such an annoying way?

I'm on OS X 10.12.5, Emacs 25.2, and the issue appears the same way if I use mouse or touchpad.

UPD. thanks to @lawlist's comment, it suffices to open the tex file and just set header-line-format to a non-nil value. The updated minimal init.el file now is

(setq mouse-wheel-scroll-amount '(1 ((shift) . 10) ((control) . 30)))
(setq mouse-wheel-progressive-speed nil)  
  • I would recommend trying to narrow down the issue to the mere existence of a header-line-format and see if you still have a problem. Without tabbar being active, you can set the header-line-format on a per-buffer basis to an arbitrary value such as hello-world. If the problem persists with hello-world in the header-line-format and tabbar disabled, then you will be one step closer to tracking down the bug. If not, then you know the conflict is with something else inside tabbar. – lawlist Jun 20 '17 at 15:44
  • 1
    thanks @lawlist! It does help narrow the bug down, although I'm still not sure if this can be fixed somehow. – Pavel Galashin Jun 20 '17 at 18:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.