3

Setting frame-title-format and icon-title-format to nil does not help.

enter image description here

  • 2
    You can try (set-frame-parameter (selected-frame) 'name nil) and (set-frame-parameter (selected-frame) 'title nil). Note, that this has nothing to do with mode-line-format. – Tobias Jun 21 '17 at 13:34
  • While I can appreciate the wish for a clean empty title bar, the icon can prove useful now and then: if you click and hold on it for a second you can drag-and-drop it on to another app, just as if you were dragging a file from the Finder – deprecated Jul 31 '17 at 19:53
9

In emacs 26 you can set ns-use-proxy-icon

(setq ns-use-proxy-icon nil)

I was able to get a completely "clean" transparent title bar:

enter image description here

Download emacs 26 for mac, add the following config to your .emacs, and restart emacs.

    (add-to-list 'default-frame-alist '(ns-transparent-titlebar . t))
    (add-to-list 'default-frame-alist '(ns-appearance . dark)) ;; assuming you are using a dark theme
    (setq ns-use-proxy-icon nil)
    (setq frame-title-format nil)
1

Install emacsmacport:

brew tap railwaycat/emacsmacport brew install emacs-mac

And then

defaults write org.gnu.Emacs HideDocumentIcon YES

  • I've being using this distribution already. And the defaults command changes nothing. – stackunderflow Aug 1 '17 at 5:09
  • Ah, then you may need to install with the --with-natural-title-bar option. – cxa Aug 1 '17 at 5:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.