1

On Ubuntu I would install emacs dependencies with apt-get build-dep emacs24, extract the emacs25.2.tar.gz and install but the dependencies don't seem to be on openSuse's zypper (package manager).

Atm I'm getting this when trying to install emacs25.2

configure: error: You seem to be running X, but no X development libraries
were found.  You should install the relevant development files for X
and for the toolkit you want, such as Gtk+ or Motif.  Also make
sure you have development files for image handling, i.e.
tiff, gif, jpeg, png and xpm.
If you are sure you want Emacs compiled without X window support,   pass
 --without-x

How should I go about getting that dependency and other dependencies needed for emacs on openSuse?

  • Please disclose posts in related forums so that we don't spin our wheels unnecessarily: reddit.com/r/emacs/comments/6misud/… This way, forum participants can read what other people have already said elsewhere. – lawlist Jul 11 '17 at 1:54
1

emacs 25.2 is already available in the editors repo. See these instructions on how to add it.

EDIT: Other openSUSE releases are available for the same repo.

  • I've added the repo, went back to Software Management. I still see only emacs 24.3 – irregular Jul 12 '17 at 0:18
  • After looking around I see that there was a "Versions" tab after highlighting the emacs package where the new version shows up after adding that repo. – irregular Jul 12 '17 at 0:38
  • The link to the editors repository returns a The requested URL is no longer available on this server and there is no forwarding address. error. – kiamlaluno May 3 '18 at 7:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.