2

Was recently required to update to RHEL 7.x and with that came a newer release of Emacs (24.3.1).

With emacs I am a big user of shells and telnet sessions within emacs so that I can easily browse the data. Have noticed with the newer emacs release that if there are updates to the shell or telnet buffers in emacs while I am browsing the data that my cursor automatically jumps to the end of the buffer vs. allowing me to continue browsing the shell while the new data collects at the end of the buffer.

Is there a method of disabling this automatic jump to the end of the buffer functionality via the emacs init file or any other means?

  • This is controlled by comint-scroll-to-bottom-on-output. Try running M-x customize-variable and setting it to nil – Felipe Lema Jul 12 '17 at 17:41
  • Tried the above but continue to have the same issue. I scroll up in the buffer to look at older data and as soon as the next update is posted to the buffer the cursor moves to the end of the buffer and the output continues. So to be clear - my objective is I would like to be able to browse within the buffer without having the window jump to the end of the buffer each time there is new input to the buffer. – craigs Jul 13 '17 at 12:43
  • As a side note - I do not have this issue with Emacs 21.4.1 but do see it with 24.3.1. Appears to be a behavior change since that release. – craigs Jul 13 '17 at 13:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.