2

I added (desktop-save-mode 1) to my custom.el towards the end to save buffers and frames. But I primarily use emacs --daemon and start an emacsclient -t. For some reason, if I use just Emacs the desktop-save-mode works but if I use the emacsclient, when I exit the client and return the buffers from the previous session load for a split second and are replaced by the *scratch* buffer.

Please let me know what I'm doing wrong or if there's a setting I can add.

Thanks!!

I've read the following posts but it seems the OP below fixed the problem by killing the emacsclient which I don't want to do. Using desktop-mode with Emacs Daemon

2
  • I believe this is related to terminal mode. See if this helps emacs.stackexchange.com/questions/19190/… Apr 15, 2019 at 0:59
  • I don't really understand the description of your problem. What do you mean by "exit" and "return"? Please clarify exactly how you do that. Also please describe what you expect to see instead of the *scratch* buffer.
    – Stefan
    Apr 15, 2019 at 14:06

0