1

How do I prevent Org Mode from including MathJax when exporting as html?

2 Answers 2

1

You can set the mathjax HTML template to be blank:

(setf org-html-mathjax-template "")

This should stop org from exporting any mathjax stuff at all.

0
2

The documentation says:

   If you prefer, you can also request that LaTeX fragments are
processed into small images that will be inserted into the browser page.
Before the availability of MathJax, this was the default method for Org
files.  This method requires that the ‘dvipng’ program, ‘dvisvgm’ or
‘imagemagick’ suite is available on your system.  You can still get this
processing with

     #+OPTIONS: tex:dvipng

     #+OPTIONS: tex:dvisvgm

 or:

     #+OPTIONS: tex:imagemagick
2
  • My documents do not include any LaTaX. Though I am sure if I did want to render LaTaX without MathJax, yours is the correct answer.
    – lookyhooky
    Commented Jul 23, 2017 at 14:16
  • Oh, I see: I misinterpreted the question. Fortunately, Alan Third did not :-)
    – NickD
    Commented Jul 23, 2017 at 20:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.