0

With Emacs started (client-daemon), I just started a New Frame, but now have a different font displayed, an unreadable cursive font. Long ago I selected Terminus from menu's Set Default Font..., then saved with menu's Save Options -- and in my init.el I see

(custom-set-variables . . .

'(default ((t (:family "Terminus" :foundry "xos4" :slant normal :weight normal :height 105 :width normal)))))

This has been fine for a long time. I know of nothing I've done to change or mess with fonts. I can correct the problem by repeating the menu choices I mentioned above, but a restart throws me back into the wrong font. What could this be?

  • Does this problem happen with emacs -q and nothing else but the code mentioned in your question and launching Emacs client-daemon? If it works with emacs -q, then it would probably be easier for you to recursively bisect your user-configuration than for us to do it for you. :) If it happens with emacs -q, then please provide the Emacs version, and operating system and any other helpful details for us to replicate the issue. – lawlist Aug 1 '17 at 21:38
  • Doesn't happen with emacs -q; it uses my Gnome/Ubuntu 17.04 system font, Then when I move my .emacs.d out of sight and start emacs, it again takes my system font. But when I change fonts through the menu, kill emacs, and start it again -- same problem with the odd-ball cursive font. I look at my .emacs (.emacs.d is empty), it has my chosen (Inconsolata) font. Will try in different window manager. Then emacs --debug-init starts with no errors, but still the odd cursive font. – 147pm Aug 2 '17 at 2:44
  • Just tried Plasma and Ubuntu Unity. Funky cursive font comes up in both with emacs --debug-init and regular icon click. I'm on Emacs 25.2.1 Gnome Metacity (Classic). – 147pm Aug 2 '17 at 2:55
1

I'll have to blame my Ubuntu/Gnome system and not Emacs. I cycled through a few system-wide font changes (Tweak Tool) -- and the problem has gone away. I've got a problem with Gnome Chrome Save, Attach dialog boxes being garbled/munged when I use Unix system (non-ttf) Terminus. Happens in LibreOffice Write dialog box, too. Will go back to a ttf font

  • If you solved your problem, mark this answer as a solution. – DoMiNeLa10 Sep 1 '17 at 12:24
  • Apparently emacs has a hook to load settings from the gnome settings management system (which is somewhat annoying for those of us who aren't using gnome and therefore don't have the tools for managing those settings). The method of disabling this is described here. – Jules Apr 18 '18 at 9:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.