8

When opening .org files, Emacs asks for a master file.

Why is that and how can I disable this feature?

I guess it is because of using latex-related packages like ox-latex and ox-beamer.

Is there a way to make the master file for .org files latex mode-specific or switch it off completely?

Thanks.

migrated from superuser.com Nov 12 '14 at 21:21

This question came from our site for computer enthusiasts and power users.

  • If you post (here in your question) the exact message you see (e.g., in the *Messages* buffer), then even someone who is unfamiliar with the particular issue you are experiencing can easily do a word-search of the source files to help troubleshoot your issue. To enable broader debugging messages, you can use this: (setq debug-on-error t) – lawlist Oct 20 '14 at 1:14
  • @lawlist It is not an error. It just says Master file : dirpath/filenames .... Then I do C-j to cancel this but it slows down loading of the file. It was not asking for this before. – Anusha Oct 20 '14 at 1:28
  • Emacs.SE is still a very small beta site. I've migrated it there now as an exception but we typically do not do this. – slhck Nov 12 '14 at 21:21
  • @slhck I thought of asking here only because it was not getting any answers on superuser. Thanks. – Anusha Nov 13 '14 at 15:12
4

Use debug-on-message to see a stacktrace when this message appears.

— Variable: debug-on-message

If you set debug-on-message to a regular expression, Emacs will enter the debugger if it displays a matching message in the echo area. For example, this can be useful when trying to find the cause of a particular message.

Source: http://www.gnu.org/software/emacs/manual/html_node/elisp/Error-Debugging.html

So, eval (setq debug-on-message "Master file") then open an org file. That should point you to why it happens. As for how to disable ... that might be worth a second question.

  • I have already asked it here and is the main purpose of asking the question as stated in the title. – Anusha Nov 13 '14 at 7:16
  • There is no stacktrace when I add that to .emacs. Its not an error. – Anusha Nov 13 '14 at 9:16
  • Hmm, maybe debug-on-message doesn't work on prompts. Good luck debugging that one! – purple_arrows Nov 13 '14 at 14:53
  • Could not find the function debug-on-message. Is it a built-of emacs or do it to install a specific package? – DJJ Sep 22 '15 at 7:11
3

Got the same problem. For me it was the reftex that I added as a hook to my org-mode, and the error appeared as soon as I upgraded one of the repositories. You need to use the option:

    (setq TeX-master t).

If you don't know where to put it, have a look at the next link. http://draketo.de/english/emacs/writing-papers-in-org-mode-acpd#sec-2-1

  • Indeed the issue come from Auctex and not org-mode. I here is the auctex doc related to this issue – DJJ Sep 22 '15 at 7:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.