3

Every tutorial for org-mode says that when you mark a TODO item DONE, it should add a line like

CLOSED:[2017-08-06 Sun 12:00]

When I mark something DONE, no such line appears. I first observed this with my heavily configured emacs, and then I went and loaded up emacs with -no-init-file and went straight into org-mode, and the behavior is the same (I still don't get the CLOSED line). Is there some option to enable to disable this somewhere? The guides online seem to suggest it should happen by default without my doing anything.

I'm using org 8.2.10 on emacs 25.2.

  • 1
    How, exactly, do you mark something DONE? I.e., what function -- M-x something, or a keyboard shortcut, or cycling the todo states, or editing the headline manually, or archiving and moving the heading/subtree to a different location of the same file or to a different file? – lawlist Aug 7 '17 at 2:11
  • 1
    I useC-c C-t. – Zorgoth Aug 7 '17 at 18:09
6

This behavior is not enabled by default, but can be configured via org-log-done. Try M-x customize-option org-log-done to see the possible values and how they behave.

If you want the CLOSED log message with the time stamp, set it to 'time:

 (setq org-log-done 'time)

You could also set this per file with an in-buffer setting:

#+STARTUP: logdone

For more details, see the Org manual section on Progress logging.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.