I've installed Emacs 25.2 on Mac High Sierra Beta. I used it together with bbatsov's prelude.

When I first run emacs --daemon, it hangs showing this output:

m15:~ g$ emacs --daemon
Prelude is powering up... Be patient, Master g!
Loading personal configuration files in 
Loading Prelude’s core...
Emacs Prelude is now refreshing its package database...
ad-handle-definition: ‘ido-completing-read’ got redefined
Contacting host: elpa.gnu.org:80
Type C-x 1 to delete the help window, C-M-v to scroll help.
Continue connecting? (No, Session only, Always) Always

Any idea how to debug this further? What is going on?

I've tried a few times and no matter what I enter as answer, it does the same. Nothing is taking CPU, nothing is being downloaded...

NOTE: I've installed Emacs via brew cask install emacs

  • Is it only the first time you try this that it hangs, or is it every time you try it that it hangs?
    – Drew
    Aug 9 '17 at 20:13
  • I've tried a few times and seems to hang every time. Aug 10 '17 at 5:52
  • Then please edit your question to make this clear. Currently it says that it hangs "on first run" etc.
    – Drew
    Aug 10 '17 at 13:39
  • What difference would have that made? :? Aug 18 '17 at 8:41

I had a slightly similar issue before (see here). I've tried the workaround and it worked.

So, if daemon ever hangs after changing things or first time you run, run emacs --insecure first, then emacs --daemon

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.