I am trying to install "evil-snipe" with evil-snipe-enable-alternate-f-and-t-behaviors on Spacemacs.

The instruction on https://github.com/syl20bnr/spacemacs/tree/master/layers/%2Bvim/evil-snipe are a bit vague.

evil-snipe-enable-alternate-f-and-t-behaviors should be set to 't'. This is in my .spacemacs file:

...
dotspacemacs-configuration-layers
'(
  evil-snipe
...
(defun dotspacemacs/user-config ()
...
(setq-default dotspacemacs-configuration-layers
          '((evil-snipe :variables evil-snipe-enable-alternate-f-and-t-behaviors t)))
...
 '(package-selected-packages
   (quote
    (evil-snipe 
...

And restarted Spacemacs.

But evil-snipe-enable-alternate-f-and-t-behaviors is nil, when I needs to be t. SPC h d v (describe variable) evil-snipe-enable-alternate-f-and-t-behaviors:

evil-snipe-enable-alternate-f-and-t-behaviors is a variable defined in ‘config.el’.
Its value is nil

Documentation:
if non nil f/F/t/T behaviors are replaced by evil-snipe behavior.

I am using Emacs 25.2.1 with Evil Spacemacs and Ivy on Linux.

If you look up a few lines in your .spacemacs, you'll see that dotspacemacs-configuration-layers already is in a setq-default. So what the docs are suggesting is that you do something like this:

...
dotspacemacs-configuration-layers
'(
  (evil-snipe
   :variables
   evil-snipe-enable-alternate-f-and-t-behaviors t)
  ...

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.