2

Elpy Configuration

Virtualenv........: None

RPC Python........: 2.7.10 (/usr/bin/python)

Interactive Python: ipython (not found)

Emacs.............: 25.2.1

Elpy..............: 1.16.0

Jedi..............: Not found (0.10.2 available)

Rope..............: Not found (0.10.5 available)

Importmagic.......: Not found (0.1.7 available)

Autopep8..........: Not found (1.3.2 available)

Yapf..............: Not found (0.16.3 available)

Syntax checker....: Not found (flake8)

Hello, I have installed all the required packages (Jedi, Rop...) for elpy, but for some reason they seem not installed, also the autocomplete not working!, any idea ?. Thank you in advance.

  • Is (elpy-enable) and (setq elpy-rpc-backend "jedi") in your config and did you run (jedi:install-server) ? – bertfred Aug 13 '17 at 8:36
  • Yes, (elpy-eneble) and (setq elpy-rpc-backend "jedi") in my config file, and I did run jedi:install-server !!. I still have the problem ! – M. Al Aug 14 '17 at 0:19
  • You can open an issue on github – bertfred Aug 14 '17 at 5:38
  • Did you install the python packages in a virtual environment or with your system python? If you installed them in a virtual environment, you need to activate it using pyvenv-activate. – MTS May 9 '18 at 19:31
0

I might misunderstood but did you install those packages only in emacs ? Because you need to install them also by using pip.

Open terminal and paste the following :

pip install jedi rope flake8 yapf importmagic

After that you should be all set.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.