2

I recently started using recentf-mode. However, during a package refresh (using auto-package-update) my recentf list gets cluttered with all the package autoloads file:

/home/polesz/.emacs.d/elpa/yasnippet-20170808.940/yasnippet-autoloads.el
/home/polesz/.emacs.d/elpa/async-20170804.2158/async-autoloads.el
/home/polesz/.emacs.d/elpa/dash-20170810.137/dash-autoloads.el
/home/polesz/.emacs.d/elpa/with-editor-20170803.917/with-editor-autoloads.el
/home/polesz/.emacs.d/elpa/web-mode-20170807.903/web-mode-autoloads.el
/home/polesz/.emacs.d/elpa/typescript-mode-20170813.1541/typescript-mode-autoloads.el
/home/polesz/.emacs.d/elpa/markdown-mode-20170812.1201/markdown-mode-autoloads.el
/home/polesz/.emacs.d/elpa/rich-minority-20170813.622/rich-minority-autoloads.el
/home/polesz/.emacs.d/elpa/org-20170814/org-loaddefs.el
/home/polesz/.emacs.d/elpa/org-20170814/org-autoloads.el
/home/polesz/.emacs.d/elpa/secretaria-20170813.1107/secretaria-autoloads.el
/home/polesz/.emacs.d/elpa/helm-core-20170810.2231/helm-core-autoloads.el
/home/polesz/.emacs.d/elpa/helm-20170813.1420/helm-autoloads.el
/home/polesz/.emacs.d/elpa/multiple-cursors-20170813.38/multiple-cursors-autoloads.el
/home/polesz/.emacs.d/elpa/pdf-tools-20170813.731/pdf-tools-autoloads.el
/home/polesz/.emacs.d/elpa/helm-bibtex-20170808.1124/helm-bibtex-autoloads.el
/home/polesz/.emacs.d/elpa/ivy-20170813.351/ivy-autoloads.el
/home/polesz/.emacs.d/elpa/hydra-20170813.1058/hydra-autoloads.el
/home/polesz/.emacs.d/elpa/org-ref-20170808.625/org-ref-autoloads.el
/home/polesz/.emacs.d/elpa/org-category-capture-20170731.2235/org-category-capture-autoloads.el

Is there a way to disable recentf saving while package update is ongoing? If not, is there a way to remove a specific directory (/home/polesz/.emacs.d/elpa in my case) from the recentf list?

5

on my side, I just ignored elpa folder by adding that:

(add-to-list 'recentf-exclude (format "%s/\\.emacs\\.d/elpa/.*" (getenv "HOME")))
  • 1
    This recentf-exclude variable is new to me, that's exactly what I was looking for. – GergelyPolonkai Aug 14 '17 at 12:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.