0

Emacs does not start in a new frame.

If I'm in a terminal running Bash and enter $>emacs the editor is opened inside this terminal, and produces exactly the same behavior as $>emacs -nw. I have what I think is an OK DISPLAY variable, :0. If I try to start it using gmrun outside of a terminal, nothing happens.

I'm using Xmonad as a window manager. I noticed something weird: if I invoke $> gmrun from the command line in a window, I get the small window to type in the command. Entering emacs and hitting enter causes emacs to open inside the terminal in which the gmrun command was executed.

What configuration items would force emacs to start without creating a new frame?

  • 2
    You don't by chance have a non-X version of Emacs installed? On Ubuntu, for instance, this would be the emacs-nox package. – Jeff Spaulding Aug 16 '17 at 22:34
1

Many linux distributions have an emacs-nox package or similar, including CentOS and Ubuntu. Make sure that the GUI version is installed; the package is called just emacs on CentOS.

Note that xemacs is a different (but related) text editor.

1

For a generic distribution to figure out whether you have a GUI version of Emacs run:

ldd `which emacs` | grep -i gtk

If that returns something you have the gtk (GUI) version of Emacs.

  • There is a Motiff GUI version also out there. I guess you can check for that with replacing gtk with motiff in that command.
  • Maybe a better way to find out your build options is to do M-x report-emacs-bug, give "Test" as the subject and scroll down to find the build options. Mine are: "XPM JPEG TIFF GIF PNG RSVG IMAGEMAGICK SOUND GPM DBUS GSETTINGS NOTIFY ACL LIBSELINUX GNUTLS LIBXML2 FREETYPE M17N_FLT LIBOTF XFT ZLIB TOOLKIT_SCROLL_BARS GTK3 X11". GTK3 and X11 are the keys here. And don't send that bug report email by accident :) – gaussian Sep 17 '17 at 14:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.