1

I just set up a new Linux workstation, and I'm having some problems with fonts in Emacs.

Evaluating this works:

(set-face-attribute 'default nil :family "Terminus")

...but the size of the face is tiny. If I try the same trick to change :size instead of :family, the results are unpredictable.

Sometimes, I can get a larger font by evaluating

(set-face-attribute 'default nil :size 197)

This font, when I get it, is too large.

Acording to the xfontsel, there are plenty of available sizes for this font that lie between the very tiny size I got at the beginning and the too-large size I got with (set-face-attribute 'default nil :size 197), but I can't get Emacs to use any one of these intermediate sizes.

FWIW, I also tried customize-face, and the results are basically the same.

How can I troubleshoot this problem further?

  • 1
    Don't know about sizes, but I strongly recommend to use :font "Terminus-16" instead. – wasamasa Aug 18 '17 at 5:19
  • @wasamasa: thanks for the suggestion, that solved the problem. More specifically, using :font "Terminus-xx", for suitable values of xx achieves the desired effect. – kjo Aug 18 '17 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.