2

Here is the screenshot

enter image description here

The mode is triggered by SPC-f-L .

I am using OSX and locate is already installed.

How can I solve this issue? Install a different version of locate or Change the behaviour of the mode?

1

according to the output of locate, it does not know the option -b, so you need to customize helm-locate (M-x customize-group helm-locate) and remove the option -b from the invocation of it („helm locate command”). Don't forget to press „save and apply” further up to make the change permanent.

try this invocation if you still have problems: locate %s -e -A --regex %s

  • 1
    From helm-locate-command documentation: Note that the "-b" option is added automatically by helm when var ‘helm-locate-fuzzy-match’ is non-nil and switching back from multimatch to fuzzy matching (this is done automatically when a space is detected in pattern). I tried to customise the helm-locate-command but still getting the errors as the "-b" option is always added automatically :-( – Liwen Jul 6 '18 at 10:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.