20

I´m new to emacs and especially org-mode, and I am testing it´s different possibilies. When trying the schedule-function with TODO, I don´t get any results displayed in the weekly or daily list.

 * TODO Get schwifty
 SCHEDULED: <2017-09-03 So>

I then set the global-keys as it is recommended in the manual with C-c a to reach the weekly schedule, but I only get a blank list of weekdates with no content. What´s wrong?

3
  • 4
    Have you added the file containing this scheduled event to the agenda file list with org-agenda-file-to-front? – Singulaere Entitaet Aug 26 '17 at 21:16
  • 2
    Thank you, that was it. Just hit C-c [ to make this happen. In the videos I was watching people had always already done that, so I missed the point. If you can update your comment to an answer, I can mark this as an answer. Where is the agenda-file list saved? – Kubo Aug 26 '17 at 22:23
  • Someone please post the answer as an answer (which can be accepted by the OP). Thx. – Drew Aug 27 '17 at 2:23
23

In order for org-mode to show events scheduled or with a deadline in the agenda-view, the org-file containing these events must be listed in the variable org-agenda-files. While one can customize this variable, the more practical way is to invoke the function org-agenda-file-to-front, which is commonly bound to C-c [.

For further details see the org-mode manual: Agenda files

1
  • org-agenda-file-to-front is bound to C-c [ by default, not C-c ]. – user14082 Aug 27 '17 at 11:38
3

Perhaps this answer will help future Doom Emacs users who run into this problem.

I think it had to do with the order in which multiple configuration files are loaded. My solution was to put the following in config.el:

(after! org
  (setq org-agenda-files '("~/org/inbox.org"
                          "~/org/gtd.org"
                          "~/org/tickler.org")))

The after! org ...) is the important bit. It will set the property after going into org mode, whereas, I believe, Doom is setting its own default location on startup.

1

Try adding a ':' in front of SCHEDULE. So it would become :SCHEDULED: <2017-09-03 So> I had a similar problem and this solved it. However if there are any side effect, I am not aware. Someone may like to comment on this.

3
  • 1
    Welcom to emacs.stackexchange. Note that in this case the solution was adding the file to org-agenda-files as described in the accepted answer. Adding ':' is not necessary and will not help if org-agenda is not aware of the file. I'm not sure what was going on in your case. – andrej Apr 12 '19 at 12:27
  • I found that I needed the extra : in the case of ** TODO Improve emacs/org skills :SCHEDULED: <2021-04-28 Wed .+1d> for an item that was in a file that the Agenda knows about. So satish's answer may be helpful if someone runs into the same issue! – Joe Corneli Apr 28 at 11:41
  • 1
    However, after discussion on IRC, they clarified to me that it really is SCHEDULED: and I found some bogus code in my startup file that was breaking the normal behaviour. – Joe Corneli Apr 28 at 13:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.