4

The new version of Totem removed the playlist feature, so I'm looking for a simple way to choose 2 or 3 podcasts from a selection of 12 or so recently cached to a ~/Podcasts directory.

The bongo music player looks simpler than EMMS, and although like EMMS it doesn't support sort-by-date in the library, it does hook into dired so I can sort most-recently-downloaded to the top in there.

Unfortunately I can't get it to play tracks continuously.

I queue a track to the playlist by pressing e in a dired buffer. I then press e with the point on another file in the dired buffer. There are now two tracks queued in the playlist buffer.

With my point on the first track I press RET and the track starts playing. When it ends, the audio stops. It does not start playing the next track in the playlist.

bongo-next-action is the default bongo-play-next-or-stop, but I've tried setting it to bongo-play-next, like so:

(setq-default bongo-next-action #'bongo-play-next)

I've tried C-u C-c C-n but that seems to makes no difference.

How do I make Bongo play more than one track without intervention?

I am using Emacs 24.4 on Linux, and mpg321.

  • I can't help you because it bugs on my emacs :( However, would you tell me the advantages of Bongo over other ones, like mpg123 that I like pretty much ? wikemacs.org/index.php/Media_player#Mpg123 – Ehvince Nov 14 '14 at 9:30
  • Also, it would be useful to know how you set the new value of bongo-next-action. – Ehvince Nov 14 '14 at 9:30
  • I've added some more detail to the question, and an answer. – BongoLugs Nov 14 '14 at 20:02
1

When the audio is playing but also after the first track stops I can see that mpg321 is till running in the background:

$ ps aux | grep mpg
me       29748  6.8  0.0 2437324 6308 ?        Ssl  19:31   0:07 /usr/bin/mpg123 --skip-printing-frames 30 -R dummy

According to the man page -R dummy means run mpg123 in command mode. Looks like bongo is maybe waiting for it to exit rather than feeding it the next track to play.

Anyway, I fixed this by disabling all the backends except for mplayer, like so:

(setq-default bongo-enabled-backends '(mplayer))

And now bongo is playing all queued tracks in the playlist.

|improve this answer|||||
0

When you start bongo,

Type M-x bongo-playlist

not M-x bongo

If not,

Press C-u C-c C-n on bongo buffer

Do it again.

|improve this answer|||||
  • 1
    I've had a hard time understanding you answer, but I think what you mean is there's both a "bongo playlist" and a "bongo library" and OP could not be using the appropriate one, is that it? – JeanPierre Dec 24 '16 at 15:59
  • I'm sorry. The content was modified to make it more understandable. – Sol Hyun Dec 25 '16 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.