1

for me flyspell is broken (or at least the default setup of it) in all versions of Emacs from 24.x - 25.x, running on OpenSuSE Leap 42.3 within KDE 5.8.7 Plasma Desktop.

The behavior is as follows: correcting a word, i.e. choosing a word from the list of suggestions, will

  1. insert the proper word at the cursor position but then
  2. insert into this proper word and at the cursor position the content of the topmost entry of the clipboard

I.e. flyspell will always copy the clipboard content 'on top of' the corrected word.

Any suggestion how to fix this would be welcome.

Mark

Self-answering & workaround: it is unclear if this is an Emacs problem or a hardware issue on Linux. It happens on a Lenovo laptop with trackpoint buttons (t460s). Mouse-button 2, i.e. the middle button, is also used for scrolling in combination with the trackpoint. It seems that flyspell(Emacs?) cannot cope with that. The solution is either to disable trackpoint scrolling with the middle button in xorg :( or to use mouse-button 3 for the 'correct word' as in How do I disable the emacs flyspell middle mouse correction?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.