1

The error message is "Warning: Opening nntp server on news...failed: >>> (error news/nntp Name or service not known); Server nntp+news previously determined to be down; not retrying;"

The strange thing is, that I have two computers with very similar OS (arch linux), sharing the same emacs config, and on one machine it works perfectly, and on the other I get the error above. The really strange thing is, that on the first (good) machine there is no error when I start gnus form emacs -Q while on the second (bad) machine, gnus is complaining (the same error message) even if it is was started from an emacs with no config loaded (i.e. emacs -Q).

Does anyone have any idea what could be wrong??? How I should even start fixing it. I tried already emacs -Q. Reinstalling emacs also -- didn't work.

I was asking around #emacs on freenode, but since I switched to ERC recently, and was trying to fix this error, I always disconnected from IRC before seeing any answers :( (stupid me).

EDIT: a bit of additional information: when I run gnus with the config activated, it does query .authinfo.pgp and asks for my GPG password... the address of the configured mail server appears among the messages, but eventually I end up with the same error message. :(

1

So the answer was trivial! If you don't set gnus-select-method, gnus looks for the default news server with the hostname "news". The machine where gnus was working properly was on a university network where the hostname "news" did resolve, while on my home network "news" failed to resolve... which caused the error message!

Since I plan on using gnus for mail only I have gnus-select-method set to '(nnnil) (and my mail server set in mail-sources and gnus-secondary-select-methods) and everything works perfectly.

Adam Sjøgren helped me figure it out on gnu.emacs.gnus https://groups.google.com/forum/#!topic/gnu.emacs.gnus/8KkUAW4NAgs

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.