1

When using IDO mode when I start searching for files it always begins in the working directory of my current file.

Usually I like this, however, if I want to search in a significantly different directory I like to press C-a to go to the beginning of the minibuffer. However, with IDO that does not work and I stay in my current directory.

Is there a way to change this and go to the beginning?

I suppose I could just type / but...old habits die hard.

1

Assuming you have ido-mode enabled, I recommend entering C-e at the minibuffer prompt which maps to ido-edit-input (instead of taking you to the end of the line). Then you will have C-a, C-k, and the rest of the original emacs bindings restored.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.