2

I had bookmarks to some files on windows servers for quick and easy access. Well, I lost access to the server (the account's password changed), so I 1) removed those entries from my bookmarks list and 2) saved the contents.

I verified that there are no references to these servers in the bookmarks, or in registers, however Emacs is still prompting me to log into these remote windows servers. I can't find out what is attempting to connect and where it's been configured.

I have to "Cancel" the Windows login/authentication dialog requests to server A three times, and server B 12 times, causing an incredibly long and painful start up process.

I've tried starting with --debug-init, but don't know where to find the log.

When I start Emacs with -Q I'm not prompted to log into those resources, but see no references to those hosts in my .emacs or any other config files. Where could it be coming from?

Thanks.

1

Normally, bookmark information is persistently saved (across sessions) in a file designated by the bookmark-default-file variable.

To investigate you problem, you could:

  1. look where your bookmarks are stored: C-hvbookmark-default-fileRET
  2. look at the contents of the bookmarks file to see if the reference to your old bookmarks are still there.
  3. If there is still a reference of the old locations, delete it using M-xbookmark-delete, save your bookmarks using M-xbookmark-save, and recheck point 2 to see if the reference has disappeared from your bookmarks file.
| improve this answer | |
1

In addition to what @Francesco said -

If you are sure that the problem comes from bookmarks, then double-check your bookmarks file(s). (I know you said that you did that, but check again.)

Check the value of variable bookmark-default-file, and look in that location (file). If you use Bookmark+ then check also the value of option bmkp-last-as-first-bookmark-file.

If you are not sure that the problem comes from a bookmark then check whether it might be coming from a file listed in the value of variable recentf-list. (This does not apply if you do not (and did not) use standard library recentf.el.)

| improve this answer | |
1

To troubleshoot the issue I started Emacs with a completely commented out .emacs init file then uncommented and executed my .emacs file one line/block at a time until came across a command that prompted the remote login authentication. ido-mode was the offending package.

I found a variable, ido-save-directory-list-file which pointed to ~/.ido.last which had references to files on the 2 remote windows servers.

I believe ido was caching the file contents of the last 100 directories I'd visited, causing windows to prompt me for authentication.

To resolve my problem, I attempted to modify and save the file, ido managed to overwrite what it had in memory back into the file. My final solution was to

  1. modify the contents of .ido.last to remove the offending references as ido2.last
  2. close Emacs
  3. delete ido.last, rename ido2.last as ido.last
  4. Start up Emacs again

There's probably an ido function to re-load ido history from the file, but I didn't have time to dig through the docs. But my blunt approach seemed to do the job!

Problem Solved!

| improve this answer | |
  • 1
    For future reference: ido-load-history and ido-save-history might be useful here. I don't see a command to remove an item from that cache, but you could evaluate something like this and then save the history: (setq ido-dir-file-cache (delq (assoc "/some/old/path/" ido-dir-file-cache) ido-dir-file-cache)). – glucas Nov 21 '14 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.