0

I have Emacs running in deamon mode at /usr/bin/emacs --daemon

I have been told to start emacs as client I can type emacsclient -c -a "" $*

However, that command starts up a new version of the GUI emacs.

I am on Ubuntu and have both the GUI and non-GUI version of emacs installed but when I run that command I only want to connect to the non-GUI emacs daemon I have running.

I can get to this by typing emacs -nw but I use emacsclient -c -a "" $* so that any time a program opens with the default EDITOR (like a git commit message) it too opens in the emacs daemon.

How can I prevent the GUI emacs from opening?

1

Replace -c with -t. The "c" is for "create-frame". "t" is for "tty". See "man emacsclient" or https://www.gnu.org/software/emacs/manual/html_node/emacs/emacsclient-Options.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.