2

I am experiencing trouble displaying unicode glyphs overall in emacs. All unicode glyphs are displayed as boxes with the number for the unicode glyph inside. To best show what I mean, the M-x list-charset-chars RET unicode-bmp looks like this: enter image description here

I am running GNU emacs version 25.2.1 on a Linux Red Hat distribution through xterm, and locale settings are en_US.UTF-8. When I inspect the font with M-x describe-font RET it displays an XLFD: -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso8859-1 This issue seems to be related to an earlier post which was left unanswered Glyphless characters? Never seen before

Any help would be greatly appreciated as I have been struggling with this for some days now.

Thanks!

  • were they displayed correctly before? what with a truetype font, dejavu sans mono for example? – contemplator Sep 20 '17 at 23:26
  • Have you tried using a different font? – Drew Sep 21 '17 at 1:01
  • Thanks for your suggestions. Yes, I have tried changing the font, but without success. When emacs loads, it says that it cannot find the specified fonts, although they are available in my ~/.fonts. If I try to set the default font with M-x set default-font RET, I only get three different fonts (XLFDs) where one is the one specified above. I suspect it's because I installed emacs with conda, and the conda version cannot find the correct path. However, in emacs version 24.5 my problem is limited to the command line only. – J. Debost Sep 21 '17 at 11:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.