0

I am using emacs 25.2 with tabbar-ruler. I also keep menu-bar-mode and tab-bar-mode enabled, at least until I become more familiar with emacs standard keybindings. Tabbar-ruler autohides both menu-bar and tab-bar and I don't see a built-in way of overriding this behavior, however I would like to. I use a 4k 40"monitor so screen space isn't an issue.

Does anyone know how to do this? Am I missing something obvious?

  • tabbar and I assume tabbar-ruler (although it's been awhile since I used it) rely upon the header-line-format (which there is only one of). So you can have the tabbar mode active, or you can have the tabbar-ruler mode active, but not both. The menu-bar is a different animal -- my father used to give me riddles when I was a kid and he would throw in "and it has feathers ...", which would make it impossible for me to guess. Then, he would tell me he threw in the feathers just to make the riddle more difficult. :) – lawlist Sep 21 '17 at 4:27
  • It looks like tabbar-ruler does indeed disable the menu-bar, although I'm not sure why: You would need to comment out that section, and M-x byte-compile-file the library, and restart Emacs: See line 1666: github.com/mattfidler/tabbar-ruler.el/blob/master/… You may or may not be using a different version, so look for (unless (eq system-type 'darwin) (menu-bar-mode -1)) in the source code. – lawlist Sep 21 '17 at 4:36

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.