2

I collect propoerties of my titles in a columnview dynamic block. But it seems to ignore the width settings from the #+COLUMNS:

Example :

#+COLUMNS: %20ITEM(Projet) %10lead(Meneur)

#+BEGIN: columnview :maxlevel 2 :id global :maxlevel 2
#+END

The Project columns is very large and i'd like to shrink it. Putting a <20> inside of the dynamic table will not survice a block update.

Any idea ?

1
  • I've hit the same issue - I've tried various ways of shrinking columns produced by the columnview dynamic block and none seem to work. Looking at v9.3 org-dblock-write:columnview function it doesn't seem to acknowledge any width character. I can see earlier versions of the function had this - ":width enforce same column widths with <N> specifier". The behaviour is specific to the dynamic block - when using the column view mode or exporting it is straightforward to control width, but this does feel like a bit of a feature gap. Did you ever find a solution or raise on the org mailing list?
    – Phil
    Jun 20 '20 at 12:43
1

You can use the :format option to set the columns:

#+BEGIN: columnview :format "%20ITEM(Projet) %10lead(Meneur)" :maxlevel 2 :id global :maxlevel 2
#+END
2
  • 1
    Great tip, thanks. I can format each columnview in a document as I want. I tested it and it works, ... except for the size of the columns, putting %20 or %5 won't change anything.
    – skizo
    Oct 6 '17 at 6:46
  • Agreed this is another way of specifying the columns, but the widths are still ignored in the dynamic block, and the result is identical to the OP.
    – Phil
    Jun 20 '20 at 12:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.