1

Since 1 month ago, I have been experiencing this issue. I already tried to launch emacs with emacs --with-x-toolkit=lucid But the problem persists, anyone experiencing the same issue?

Fatal error 11: Segmentation fault Backtrace: emacs[0x507999]
emacs[0x4ee55c] emacs[0x50613e] emacs[0x506363] emacs[0x5063cf]
/usr/lib/libpthread.so.0(+0x11da0)[0x7fbbaeb47da0]
/usr/lib/libgobject-2.0.so.0(g_type_check_instance_is_fundamentally_a+0x31)[0x7fbbb31fb4d1]
/usr/lib/libgobject-2.0.so.0(g_object_unref+0x15)[0x7fbbb31da8e5]
/usr/lib/libgtk-3.so.0(+0x20e04d)[0x7fbbb444804d]
/usr/lib/libgobject-2.0.so.0(g_object_unref+0x1a2)[0x7fbbb31daa72]
/usr/lib/libgtk-3.so.0(+0x11afdc)[0x7fbbb4354fdc]
/usr/lib/libgtk-3.so.0(+0x1681b1)[0x7fbbb43a21b1]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0xb1)[0x7fbbb31d5dc1]
/usr/lib/libgobject-2.0.so.0(+0x22622)[0x7fbbb31e8622]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0xa75)[0x7fbbb31f0c85]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x8f)[0x7fbbb31f169f]
/usr/lib/libgtk-3.so.0(+0x39276e)[0x7fbbb45cc76e]
/usr/lib/libgobject-2.0.so.0(g_object_run_dispose+0x48)[0x7fbbb31dc3d8]
/usr/lib/libgtk-3.so.0(+0x1681b1)[0x7fbbb43a21b1]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0xb1)[0x7fbbb31d5dc1]
/usr/lib/libgobject-2.0.so.0(+0x22622)[0x7fbbb31e8622]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0xa75)[0x7fbbb31f0c85]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x8f)[0x7fbbb31f169f]
/usr/lib/libgtk-3.so.0(+0x39276e)[0x7fbbb45cc76e]
/usr/lib/libgobject-2.0.so.0(g_object_run_dispose+0x48)[0x7fbbb31dc3d8]
/usr/lib/libgtk-3.so.0(+0x1681b1)[0x7fbbb43a21b1]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0xb1)[0x7fbbb31d5dc1]
/usr/lib/libgobject-2.0.so.0(+0x22622)[0x7fbbb31e8622]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0xa75)[0x7fbbb31f0c85]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x8f)[0x7fbbb31f169f]
/usr/lib/libgtk-3.so.0(+0x39276e)[0x7fbbb45cc76e]
/usr/lib/libgobject-2.0.so.0(g_object_run_dispose+0x48)[0x7fbbb31dc3d8]
/usr/lib/libgtk-3.so.0(+0x1681b1)[0x7fbbb43a21b1]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x19d)[0x7fbbb31d5ead]
/usr/lib/libgobject-2.0.so.0(+0x22622)[0x7fbbb31e8622]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0xa75)[0x7fbbb31f0c85]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x8f)[0x7fbbb31f169f]
/usr/lib/libgtk-3.so.0(+0x39276e)[0x7fbbb45cc76e]
/usr/lib/libgobject-2.0.so.0(g_object_unref+0x133)[0x7fbbb31daa03]
/usr/lib/libgtk-3.so.0(gtk_container_remove+0xa6)[0x7fbbb43a0656]
emacs[0x4e2e51] ... [1]    10803 segmentation fault (core dumped) 
emacs --with-x-toolkit=lucid
  • 3
    This doesn't explain the segfault, but --with-x-toolkit is a configure option when building Emacs, not a meaningful runtime option. – Basil Sep 23 '17 at 2:07
  • (See the Emacs build/installation and command line arguments documentation for further clarification on my previous comment.) – Basil Sep 23 '17 at 2:30
  • 1
    You might want to try emacs -nw in an xterm or a console. That should stay away from gtk and may avoid the segfault. If that works fine, it is more likely IMO that the fault lies with gtk (or one of the libraries that it depends on) than with emacs itself. You might want to submit a bug report and include all the information that you have not included here - what OS, what version, what version of gtk, what version of emacs, etc. FWIW, I'm running emacs 26.0.50 on Fedora 24 and I have not seen segfault. – NickD Sep 23 '17 at 2:59
  • Did you heavily customize your desktop appearence? I've seen some other programs crash on GTK with poorly implemented themes. – wvxvw Sep 23 '17 at 8:59
  • 1
    A crash indicates an Emacs bug, especially if you can reproduce it from emacs -Q (no init file). Please consider reporting the bug: M-x report-emacs-bug. – Drew Sep 23 '17 at 15:15
1

I had a similar problem: in the segfault message, I had a line mentioning the file /usr/lib/libpthread.so.0.

I found that the problem was related to the use of the Linum package. I had

'(global-linum-mode t)

in my init file. The segfault disappeared after commenting this line (or deactivating linum-mode).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.