0

my emacs shell mode screen shot ...

emacs shell mode screen

Normal shell looks like this...

shell mode normal

I have .emacs file empty..

emacs version 24.5.1

I already tried this https://stackoverflow.com/questions/20663005/why-does-shell-mode-display-some-rubbish-code

[I copy the code provided in solution of above question in my .emacs file but its not working for me...]

  • This is two separate issues, one being a too fancy prompt that you'll need to deactivate inside Emacs, the other being bracketed paste where you need to know the shell to deactivate it. – wasamasa Sep 25 '17 at 6:01
  • I am new to emacs .....can you tell me how to do this in little more details ....or any link ..... – AKGarhwal Sep 25 '17 at 6:03
  • First you'll have to tell us what shell you're using. – wasamasa Sep 25 '17 at 15:27
  • OS Ubuntu 16.04 Shell : zsh – AKGarhwal Sep 26 '17 at 3:57
0

Add something along the following to your .zshrc:

if [[ $TERM == dumb ]]; then
  PROMPT=<normal stuff>
  unset zle_bracketed_paste
else
  PROMPT=<fancy stuff>
fi
| improve this answer | |
0

I added this to .zshrc file

# turn off ZLE bracketed paste in dumb term
# otherwise turn on ZLE bracketed-paste-magic
if [[ $TERM == dumb ]]; then
   unset zle_bracketed_paste
else
   autoload -Uz bracketed-paste-magic
   zle -N bracketed-paste bracketed-paste-magic
fi
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.